Minor isues on my Brera - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-11-15 Thread Starter
Status: -
Alin Anicai's Avatar
Join Date: Nov 2015
Location: Timisoara
County: Romania
Posts: 2

Member car:


Minor isues on my Brera

First Hi to all.

Second I hope that the problems on my car are minor and can be fixed easyly

So my first problem seems to be with the ac unit or something over there.
Wen is on cooling mode the driver side(in my case left side) the air is not cool enogh, it actually feels mild hot air but the passenger side is frezing. This was the first problem I noticed.
I have found that there is a dor or something like that, that can be stuck on mid moving betwen cold an hot air.
I haven't try to disconect my battery yet but I want to know how hard can be to replace that dor.

The second problem is with my wipers sensor, I think. Wen engaging the lever to auto position in the dash board i have a mesage that says autommatic sistem is not available. Not a major problem but I want to have everything working properly on my car.

The third, and this seems to be a litlle bit major. I have an oil consumption.
When I bought the car 2 monts ago i have to take'it from 550 km away from home. On that road the oil level droped with two lines. I put in back the exact quantity of oil to the engine to have the right level and now after almoust 2000 km the level drops with two lines. I don't know how much this is in quantity but i know that there should be no oil consumption.
There is no leakege under the car or on engine bay.
I don't know if this normal or not. The car that i owned before haved almoust 300 grams of oil consumption betwen changes( i change the oil every 10000 km on every car i own)

And this seems to be all my problems for now.

The car is a 2006 Brera with 2.4 engine.

Again, excuse my grammar but english is not my first language.
Alin Anicai is offline  
Sponsored Links
Status: All Hell's A-Coming
AO Platinum Member
Tata4Now's Avatar
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 26,915
Hi welcome to AO.

You A/C issue sound like a flap problem.
There are plenty of threads in this lounge
concerning cold/warm air from each side.

Check the sensor connection which is
behind the plastic cover above the rear
mirror on the windscreen.

Tata4Now is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , isues , minor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome