I've killed me Brera - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 24-10-15 Thread Starter
Status: -
Join Date: Jan 2015
Location: United Kingdom
County: Greater London
Posts: 3

Member car:


I've killed me Brera

2.2 JTS, used it to jumpstart a friend's car which it did successfully, now mine will not start.

It unlocks and locks from electronic key, lights flash and alarm beeps, however no response when the key is placed in the slot - the usual clicks and whirrs do not occur and nothing comes up on the screen.

gmoray is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

See page 78-79 in the owner's manual, under the drivers seat there's a fuel cut out switch press that & then under the plastic cover next to the battery postive terminal press the electronic power supply rest button. See if that works
IAMBRERA is offline  
Status: turning heads everywhere
AO Silver Member
lussoman's Avatar
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 3,931
I hope you put the jump leads on correctly.
Positive (red) to positive, negative (black) to metal (earth).
Heard a story of someone killing a Porsche 928 back in the day by getting this wrong...
lussoman is offline  
Status: All Hell's A-Coming
AO Platinum Member
Tata4Now's Avatar
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 26,881
Check main battery fuses.

Never jumpstart, always use a battery pack.
Tata4Now is online now  
Status: Feeling sleepy
AO Member
jparkin486's Avatar
Join Date: Jul 2014
Location: Hampshire - Darn Sarf!
County: Hampshire
Posts: 367
Hope I'm not bringing bad news. I had a CRV that needed a new battery. The RAC man said never jump start cars as you can wipe the immobiliser codes. This then requires a trip to the dealer to reset them.
jparkin486 is offline  
Status: All Hell's A-Coming
AO Platinum Member
Tata4Now's Avatar
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 26,881
There have been a handful of instances of fried ECUs after jump starting
over the years on AO. (Either the jumpee or the jumper.)

With Li-Ion jumpstart packs now around 50 better to carry one of those
than a set of jump lead, IMHO.
Tata4Now is online now  
Status: -
AO Member
Chipmik's Avatar
Join Date: Sep 2013
Location: Denmark
County: Nordjylland
Posts: 322

Member car:

159 2,4 JTDm

You probably put the cables on battery-terminals after one of the big fuses & not straight on the battery? So it could help the flat battery, but when he started, it pulled that much current the fuse blew.
Chipmik is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , killed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome