2.4 oil level sensor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By stuart.macintyr
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-09-15 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Renfrewshire
Posts: 172

Member car:

159 2.4 - B100

2.4 oil level sensor

Hi just in case this helps anyone else. I have never had the oil level show up on the dash after putting the key in, so i knew the oil level sensor (sender) was faulty, but didn't really care.

Anyway after getting the clutch done i ended up with an oil leak. tracked it down to the oil level switch. the garage must have hit it with the drive shaft then they were re fitting it. the green plastic was broken and oil was leaking from it. It is almost directly in line of the driver side drive shaft, about half way long.

Unlike the petrol's (2.2 is sump off, v6 is engine out) the sensor on the 2.4 sticks out the rear of the sump, about a foot below the fuel filter. You can get to it from under the car and do not need to take the under tray off, there is a rectangular cutout at the rear of the under tray that if you look up and at the sump, just behind the drive shaft you can see the green plastic of the sensor. All you need is to un-clip the cable, then using a 19mm spanner undo the sensor. It is above the oil level so no oil should leak out (unless you have overfilled). Then replace with the new sensor, tighten and re attach the cable. In my case i found out why the oil level never showed on the dash - the bottom part of the sensor was missing, must have snapped of and is laying in the sump. The sensor end, the part that gets inserted into the sump is about an inch of metal then an inch and half of plastic, the plastic part of mine was missing.

anyway changed the sensor in less than 20 mins (including getting the car on stands) - no oil leak and now have the oil level show on the dash after inserting the key.

Part number for the 2.4 is '55200021' -listed as 'sending unit' (but it is the oil level switch/sensor)

places like shop4parts and alfaworkshop dont seem to stock it, was 30 from the closest alfa dealer, took 3 days to order in.
matty74 likes this.
stuart.macintyr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

level , oil , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome