sluggish drive - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 2 Post By R159
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 07-08-15 Thread Starter
Status: -
Join Date: Aug 2015
County: -
Posts: 1
sluggish drive

My ***** Romoe 159 appears to be dragging when driving. i noticed this after collecting it back from the garage where it had body repairs after a minor accident damaged the front left. The garage assured me that they did not touch the brakes. The car when I am driving feels like I am driving with the hand break engaged. Has anyone had such an experience with their car?

Last edited by Bill69; 07-08-15 at 21:47.
Bill69 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Hi Bill, I've moved your thread to the 159 tech lounge, you should get the help you need for your Alfa Romeo in here.
classicgal93 is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
Hi bill, think you'll need to give us a bit more information on your car, what model is your 159, (spec and engine), as they all have different problems (Ti models have different brakes than many lusso etc).

Have a read of the stickies though, lots of info there.

Any spelling/ grammatical errors are purely there to annoy!
giblets46 is offline  
Status: -
AO Member
Join Date: Mar 2011
Location: United Kingdom
County: Lancashire
Posts: 147

Member car:

159 2.4JTDm

I had this on my 156- Seized caliper!
Yatesuk is offline  
Status: -
AO Member
Join Date: Dec 2013
Location: United Kingdom
County: Rutland
Posts: 466

Member car:

Alfa159 2.4

You should be able to feel the difference between the temps in the discs after a drive, put a glove on first unless you don't need finger prints....
Alfa.Romeo and Phanatic like this.
R159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

drive , sluggish

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome