Alfa 159 1.9 16V Cams Jumped out of timing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-07-15 Thread Starter
Status: -
Join Date: Aug 2009
Location: I would rather not say
County: -
Posts: 6

Member car:

156 2.4 jtd

Alfa 159 1.9 16V Cams Jumped out of timing

Here is a good one for you all:

Don't ignore a squeak/rattling from your aux belt. My crank pulley fell apart, trashed the aux belt which then jammed under the timing belt. The engine survived intact but....the cams were knocked out of timing. The two cams are connected by toothed cogs and one of my cogs had moved upsetting the timing. Had to use screw in cam locks to reset and after putting it all back together it runs perfectly!
fmcandclc is offline  
Sponsored Links
Status: -
AO Member
LukaCrc's Avatar
Join Date: Dec 2014
County: -
Posts: 82
Exactly same problem happened to me week ago.. Did the same hard job as you do...
LukaCrc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , 16v , alfa , cams , jumped , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome