159 1.9 qtronic issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-07-15 Thread Starter
Status: -
Join Date: May 2015
County: -
Posts: 1
159 1.9 qtronic issues

Hi guys. I bought the foregoing a few weeks ago and have a bunch of issues, so if you have any ideas...

Symptoms, sluggish pulling away until it hits 2000rpm. Sounds like it is hunting from cold and the rev counter bounces. Engine takes to 'pulling', feeling like it is pulling some rubbish through, which could be bits of dislodged carbon.....

The garage I bought it from have been great but we are all scratching our heads. Items changed: EGR twice (which is why the pulling may be caused by some dislodged carbon), turbo has been reconditioned, boost valve cleaned, a couple of vacuum hoses had collapsed and have been replaced. Air flow meter has been swapped for know we know works.

No error messages are being thrown up.

Any thoughts?
th3laird is offline  
Sponsored Links
Status: Why is the rum gone?
AO Member
Join Date: May 2012
Location: United Kingdom
County: Greater Manchester
Posts: 627

Member car:

159 2.0JTDm SW

Fuel filter.

(that would be my next thought after all you have done)

FiremanAxe is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , issues , qtronic

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome