P0094 and P0091 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 05-07-15 Thread Starter
Status: The Alfa bug bit again!
AO Member
Sir Plug's Avatar
Join Date: Jan 2008
Location: New Zealand
County: Auckland
Posts: 41
Images: 12
Angry P0094 and P0091

Help. The 159 has broken down twice, now and both times the fault code is the same. P0091 and P0094 Fuel Pressure (high pressure pump input regulator).

First, what is the pump input regulator and secondly, is this a sensor fault or a regulator fault??

Are there any other causes of the same code?? Fuel filter, scavenger pump, leaky injector, etc??

Any help gratefully received.......

Once the ignition has ben turned off she starts and runs fine. The only other issue I remember is the occasional 'misfire/hesitation' feeling as you come off the gas and then go back on it.

2009 159 1.9 JTDm 16V with 65,000km on the clock.
Sir Plug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

p0091 , p0094

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome