Calling Spider owners with roof problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By evoke
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-06-15 Thread Starter
Status: Besotted
AO Member
evoke's Avatar
Join Date: Oct 2012
County: -
Posts: 230
Calling Spider owners with roof problems

Okay, if your roof is actually broken then ignore what I say.

However, if you get the 'temporary roof failure' messages regularly then this may help you. A couple of months ago I was getting a lot of these error messages when raising or lowering the roof on my Spider. I got used to releasing the button and trying again until the roof was successfully raised or lowered.

A few weeks my service was due and the garage checked the condition of my battery. They said it was still passable as the engine cranked successfully but the battery would need to be replaced soon. I asked them to replace the battery.

Since then, I've had zero roof errors - that's after about a total of 16 roof operations so far and the roof opens and closes much quicker and much more smoothly. I would be surprised if it's coincidence.

So, get the condition of your battery checked before splashing out big money on roof repairs. A lot of places will check your battery for free so it's at least worth doing before looking elsewhere for the issue.
147virgin likes this.
evoke is offline  
Sponsored Links
Status: turning heads everywhere
AO Silver Member
lussoman's Avatar
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 3,935
Good post Evoke.
Mine's the same vintage as yours so I'm probably due a fresh battery.
Even though my roof is very stop/start with all the near clashing of parts picked up by the sensors, it does really struggle to move when there's nothing in the way.
The hydraulic fluid level looks okay with no sign of leaks.
It could well be down to the battery on mine.
lussoman is offline  
Status: Driving in an Alfa wonderland
AO Member
SpiderSaint's Avatar
Join Date: Aug 2014
Location: South proper Southampton
County: Hampshire
Posts: 763
Could be down to th battery, touch wood, I've never had a roof message
SpiderSaint is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

calling , owners , problems , roof , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome