159 Using Water & Oil... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-05-15 Thread Starter
Status: Poorly Car!
AO Member
PME's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Lincolnshire
Posts: 18
159 Using Water & Oil...

My 159 JTDM 2.4, 125k miles, FSH, has started to consume 100ml and month, but more alarmingly 2 litres of coolant a week. I've had the cooling system pressure tested, no visable leaks, I fear the worst, any suggestions?
More diagnosis criteria, intermittent loss of power, turbo spools up ok and engine revs to 3200rpm no higher, but no power at all, lasts for approx. 1 minute max, then back to full power.
Could be Mass air flow meter sensor, Exhaust Gas Regeneration unit clogged?
It has rough idle at low revs coughing and jerking along if in traffic.
I had a dashboard fault show up recently “Anti-pollution filter clogged”!
No sign of mayonnaise.
Otherwise engine is just as powerful as always, except of course for the ever present turbo lag under 1500rpm.
Planning a 60 mile trip to see Lewis at Alfatecnico, when I can get time...

Last edited by PME; 11-05-15 at 20:13. Reason: Update info.
PME is offline  
Sponsored Links
Status: -
AO Silver Member
BuonGiorno's Avatar
Join Date: Aug 2013
Location: Russian Federation
County: St. Petersburg
Posts: 2,470
Since no leaks coolant may go to oil ( A ) or exhaust ( B ).
A. Check oil level. Must be to high.
B. Check coolant pipe engine idling. Must be springly enough.
Alles simple.
BuonGiorno is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , oil , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome