Engine noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-05-15 Thread Starter
Status: -
AO Member
Join Date: Jul 2013
Location: United Kingdom
County: Staffordshire
Posts: 65
Engine noise

my 1.9 jtdm 159 seems to have developed a noise in the engine bay which does not sound right but with no obvious cause. It sounds like additional vibrations but performance does not appear to be compromised and no eml lights present. It is a rattle/vibration or possibly could the aux belt cause a noisey engine?

I have had the timing belt replaced with water pump and clutch and flywheel in the last 6 months so are there any other parts which may cause a noiey engine or diy things I can check before getting it into a garage?

Would the dreaded swirl flap issue cause vibration/noise mainly detectable when idling?
Callaghan82 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Mar 2013
Location: United Kingdom
County: Worcestershire
Posts: 173

Member car:

159SW 1.9JTDM

Have a quick check that your resonance box has come loose from its mount, the rubber on mine had worn and it kept popping out and rattling.
MattB159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome