Rear creaking noise... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 24-04-15 Thread Starter
Status: Enjoying my Alfa
AO Silver Member
sargent's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: West Midlands
Posts: 1,309

Member car:

159 1.9JTDM

Rear creaking noise...

The last week my 159 has developed a rear creaking noise. Checked the bumper. It seems maybe the suspension?

Have a look at this photo. Can anyone help??
Attached Images
File Type: jpg IMG_7903 copy.jpg (127.7 KB, 45 views)
File Type: jpg IMG_7904 copy.jpg (101.2 KB, 42 views)
sargent is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

New top mounts & springs should sort things out
IAMBRERA is offline  
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,927
Images: 12
I think you mean the rear LH side noise we have been chasing in another thread. I don't think it comes from this top mount.

We describe it as a Squidgy/Rattle like the spare wheel being loose.

Others have changed the anti roll bar links with no improvement. There are a couple of things to check before getting too involved. Start with a 2 person check. You inside and somebody else shaking the exhaust ends. If this is the same noise start with ensuring the spare wheel is tight. The next thing is to make sure there are no stones laying on top of the silencers which make contact with the floor over bumps.

After that I'm having some success with the trailing arm bush. At the front there appears to be a sliding bush (axially). I've got some graphite spray on to the bush and it is much improved. I thought it was cured but the noise has returned in a lighter note. It's more Squidgy and less Rattly. Before this repair I could make the noise happen every time by driving off of a kerb. As the front wheel left the kerb the rear wheel compressed and the noise happened. Now it won't happen. I really only get it now over long speed tables. The other change is the affect of weight. The rattle really intruded with 4 people on board. Today I had four people and just a faint squidgy noise over long undulations.

So now I'm going to get some grease up on to this bearing.

By the way. While doing this repair I also noted that the handbrake cable fouls the exhaust rubber on the Left Side so I did put grease between the two and tie wrapped the cable closer to the trailing arm so I will have another look at this for evidence of touching. I suppose I could take off the tie wrap and see if the noise returns at full squelch but if it is this I would have thought it would happen from new.
Old Engineer is offline  
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,927
Images: 12
A picture of my top mount to compare...
Attached Images
File Type: jpg Unloaded.JPG (80.3 KB, 38 views)
Old Engineer is offline  
Status: Burning clutches
AO Member
Join Date: Sep 2005
Location: Cyprus
County: Nicosia
Posts: 206
Images: 6
I agree with Old Engineer on this one. My rear left spring was sheared, dropping that wheel about 1cm more than the rest. It had sheared in the part inside the top mount and was not easily seen without removing both.
xenkof is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

creaking , noise , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome