Issues with a Spider - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 24-04-15 Thread Starter
Status: Alfa, Football, Family.... In that order
AO Member
Karn's Avatar
Join Date: Mar 2007
Location: Jersey
County: -
Posts: 752

Member car:

156 2.5 v6

Issues with a Spider

My brother has the Spider in the picture below but he has a couple of issues that the one and only main dealer is asking a fortune to just diagnose.

1. Radio code. Is there a number he can call to get the code? The garage are asking for so much paperwork and will only issue the code if he takes it all down to them. Is it possible to do this over the phone with the relevant paperwork?

2. Electric windows and roof. The dash display is constantly saying the roof closing procedure is incomplete and the electric window on the drivers side will not go up fully. There's a one inch gap and it refuses to go any further. I believe the issues are related as once the door is closed the windows should automatically nip up into the hood. As far as I'm aware the hood will not even open anymore.

Has anyone else had this problem. Your help or advise would be appreciated.
Attached Images
File Type: jpg IMAG2171.jpg (46.6 KB, 4 views)


Owning an Alfa is not a matter of life or death...... It's much more important than that.
Karn is offline  
Sponsored Links
Status: Long live the nice weather
AO Silver Member
GT Paddy's Avatar
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 1,129
Hi there

You need to post this one in the 946 Spider section, this one is for the previous generation. I am sure they will have an answer for you.
GT Paddy is offline  
Status: Life is good atm. I do not take that for granted.
Global Mod Team
PaulR's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Suffolk
Posts: 21,474
Spotted the above and I have moved it - I hope you get an answer!
PaulR is offline  
Status: the proud father of a Spider!
AO Member
Spiderman_Steve's Avatar
Join Date: Jan 2015
Location: United Kingdom
County: Dorset
Posts: 137
Images: 4

Member car:

948 Spider 2.4

Spiderman_Steve is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

issues , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome