Alfa Romeo Spider Fuel Guage Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-04-15 Thread Starter
Status: -
Join Date: Dec 2014
Location: United Kingdom
County: Hertfordshire
Posts: 1
Alfa Romeo Spider Fuel Guage Problem

Hi All

I have been working abroad for the past 2 months and came back to find my car battery was dead. Whenever I pushed the start/stop random lights flashed i.e hazard lights, indicators and a strange noise (which was the alternator).
I managed to jump the car with my neighbours Range Rover. All my problems seemed to be solved except the fuel gauge was reading zero. I therefore, top the whole tank with fuel but the gauge continued to read zero.

I don't think it is the gauge because the light beside it is flashing indicating the tank is empty.
I don't think it is the float inside the tank because if it got stuck it would have got stuck at the level with the remaining fuel inside but it is reading completely empty.

I personally believe it is the sender unit. Although I can get to the fuel compartment underneath the driver seat, I cannot get any further because the circular panel appears to have no bolts to unscrew it.

Any hints or suggestions.

I have it booked in to Alfa Romeo tomorrow morning but would prefer not paying 150 for them to just plug in the computer. Especially if it is a simple problem.

Many thanks in advance.

Alfa Romeo Spider 08 Limited Edition JTS 2.2
Hemingway254 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2013
Location: United Kingdom
County: Rutland
Posts: 466

Member car:

Alfa159 2.4

I'd fill it up, get some leads and software on order much cheaper than a dealer... Or go to an independent like autolusso, I'm sure they wouldn't charge that much for 10 minutes work. On my fuel gauge the reserve light is either on or off, it doesn't flash.
R159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

alfa , fuel , guage , problem , romeo , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome