aero wipers not clearing screen solution? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 04-04-15 Thread Starter
Status: prohibition sucks
AO Member
alfacapone's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Derbyshire
Posts: 249
aero wipers not clearing screen solution?

just had my windscreen replaced - [another story of woe] and gone to replace the old flat blades with nice new ones.

Maybe the shape of the glass is slightly flatter but i find the wiper arm travel toward the screen has "bottomed" out before the middle of the blade is comfortably pressing on the screen just right in front of the driver for about 4 inches of sweep. With the curvature of the flat blades and the limit of the arm travel to the glass I find the drivers side is not clearing too well.

So to add pre-load on the blade in the centre I can think of three things [ignoring moving the glass further out from the cabin!!]:
  • cut off the arm hinge limit tabs on the joint of the arm and somehow increase the spring load in the arm
  • try to adjust the motor assembly position so the spindles are angled more to the screen
  • put a bit of a kink in the arm to bend the blade end closer to the glass
Sorry for the poor problem description, anyone had any other solutions to this problem? And I'd prefer not to source a more convex screen!

alfacapone is offline  
Sponsored Links
Status: Considering a ReMap
AO Silver Member
147virgin's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: North Lanarkshire
Posts: 2,937
Images: 2
Seems a bit extreme? Would suggest buying another set of blades first?.....just in never know
147virgin is offline  
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

Try rain x rain repellent, no need for wiper after using it
IAMBRERA is offline  
Status: Powerflex Mk4 - Non Squeak Edition
Club Member
Membro Premio
JabawokJayUK's Avatar
Join Date: Jul 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 3,378
Images: 31
There are a few issues with the wipers but what you are describing is most likely down to the blades themselves. I've tried a few different types and so have others. There was a thread a while back about a new set of blades that were slightly shorter than reconnected that seemed to give much better clearance than others so worth a brief search on this forum as there was a link to buy them.

In terms of fixing what you have, grab the arm and just give it a little bend where it bends already to increase the pressure on the window. It doesn't need much, maybe 1-2mm of actual arm movement and that will give you the extra pressure on the screen. I have had to do this to mine, post windscreen replacement, so there could be something in the curvature of the screen being slightly shallower than stock.

2008 159 TI 2.4 JTDM QTRONIC
My Car Details______
Project Halo Wiki____
Project Halo Page____
JabawokJayUK is offline  
(Post Link) post #5 of 8 Old 05-04-15 Thread Starter
Status: prohibition sucks
AO Member
alfacapone's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Derbyshire
Posts: 249
thanks for all the suggestions : bending arme first; straightening the blades a bit after if possible [thin spring steel], rainex third. Nice job for a Bank Hol Monday!!
alfacapone is offline  
Status: -
AO Member
Join Date: Jul 2009
Location: Top of the A303
County: Hampshire
Posts: 187

Member car:

159 ti 2.0JTDm

Hello alfacapone - Are the rubber bushes at the three mounting points of the motor/linkage assembly ok? It seems they tend to distort so that the linkage assembly tilts away from the screen. I suggest to take a look at this thread if you have not seen it already...

Fitting a large washer on top of the rubber bushes worked perfectly for my 159.

eriksmate is offline  
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,591
Before you start bodging try lubricating the arm pivots.
Dave Brand is online now  
Status: Bleed Alfisti Now
AO Member
Napertony's Avatar
Join Date: Feb 2015
Location: United Kingdom
County: Lancashire
Posts: 25
If you are looking at new blades, I recommend (of all places) Halfords for new wiper blades. Go an inch bigger on the passenger and suggested on the driver, they work a treat, and the the wet North Western weather we have had this Winter\Spring has put them through their paces.
Napertony is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

aero , clearing , screen , solution , wipers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome