159 2.2 JTS Oil Sensor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-03-15 Thread Starter
Status: -
AO Member
Uriziel's Avatar
Join Date: Mar 2015
Location: Estonia
County: Harjumaa (Tallinn)
Posts: 12

Member car:


159 2.2 JTS Oil Sensor


I'm new to the forum and also a fresh and proud Alfa owner.

I believe the oil sensor on my 159 2.2 JTS is not working. (Original part nr. 55192304)
I've done some research and for instance the oil lamp indicator on the dashboard should light up just after ignition. For me it doesn't show up at all. Also the oil temp gauge isn't moving.

I hooked a diagnostics machine to the car and got 2 errors. B1390 oil temp sensor short to gnd and B1001 that is a general code that has different fault under it, among them oil level sensor fault.

I tried cleaning the connector that comes out of the sump and its counterpart but still nothing. The diagnostics showed that the oil level indicator and the oil temp gauge itself are working when toggling them.

My question is that is there an alternate part to the original. Since i know most of the parts are shared between several car manufacturers but i haven't found any alternate parts for the oil sensor other than the original that costs about 200. And none of the cart part lookup engines that i've found have it even listed.

It's not a big deal though since i'll check the oil level manually anyway and the oil temp usually isn't an issue for me. But still would like to change it and have the electronic indicators working. I hear it's a common issue and perhaps some of you have some knowledge of what the alternative part can be if any.

Uriziel is offline  
Sponsored Links
Status: -
AO Silver Member
BuonGiorno's Avatar
Join Date: Aug 2013
Location: Russian Federation
County: St. Petersburg
Posts: 2,471
No it is not unfortunatelly. 55192304 is only article number to replace it properly.
Normally the gauge itself is OK and the problem is created by inner socket because of floating in oil.
Here in Russia this socket is normally repaired ( soldered ) because of both article price and lead-time.
Oil pan is to be stripped for this repair.
I have posted some pictures for this here in similar threads.
BuonGiorno is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

oil , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome