Brera earth point no longer earthed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hmmm Brera earth point no longer earthed

After getting my car back from the dealer
(after crash repairs) my sub woofer hasn't
been working.

After checking the fuses, spent some time tracking
the problem with multimeter.

Hmmm, power okay, but no earth! WTF?

On opening up the little hole for the rear light cluster
(where I'd attached the stripped earth wires under the
retaining bolt) I notice someone has crimped a ring
connector. So someone's obviously messed
with my wiring.

Thing is, the middle retaining bolt no longer gives
a good earth. Why would that be?

Anyway, fixed it by earthing to one of the other
retaining bolts. Just in time for me hols.

Sponsored Links
Status: 660Nm of torqueystuff!
AO Platinum Member
Hunter's Avatar
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Re: Brera earth point no longer earthed

Huh Why would they do this Nev

Does that mean you car could have accumulated static charge and not been able to 'earth' said charge Or are you refering to battery earth
Hunter is offline  
Status: - Update
Posts: n/a
Re: Brera earth point no longer earthed

The bolt I used (as an earth point) was earthed before the repair.

Now it isn't.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , earth , earthed , longer , point

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome