159 Engine Temp - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-03-15 Thread Starter
Status: -
AO Member
Join Date: Jun 2007
Posts: 187

Member car:

Alfa 166 Ti

159 Engine Temp

From a cold start my 159 takes about ten minutes to reach a level 90 degrees on the temperature gauge. No problem there. On another day, again from a cold start, if I put the heater on when the gauge hits between 70-80 degrees, it then takes a lot longer to hit 90 degrees. When it does hit 90 eventually, it drops back to 80 or so degrees when it should be running at a level 90.

I am assuming there is a thermostat issue but need to know if there is anything else I should check. Today from a cold start, I let it hit 90, then put the heater on, and the temperature dipped towards 80. It took a few minutes and then it was back at 90 and remained there. The thermostat with housing is £120 and a right pain to fit. Before I contemplate this, are there any checks I can do to isolate the problem ? Thanks.
fnkmcr is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Renfrewshire
Posts: 172

Member car:

159 2.4 - B100

Sounds like the stat to me. You can get them on ebay much cheaper than that! I did mine and it wasn't too bad a job, just a lot of coolant on the drive
stuart.macintyr is offline  
Status: -
AO Member
Join Date: May 2014
Location: United Kingdom
County: -
Posts: 392

Member car:

159 2.4 JTDm

First - the gauge is absolutely useless - get some kind of obd interface and get data from the ECU (engine runs at anywhere between 70-100C - but gauge will sit at 90C) - and then go from there.
jacekowski is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , engine , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome