Diesel Loss of power under load - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-03-15 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Renfrewshire
Posts: 172

Member car:

159 2.4 - B100

Diesel Loss of power under load

Hi thought I would share this. About a year ago I had an issue where the car (159 2.4) lost all power on the motorway as I started to overtake. Went into a sort of limp mode till I pulled over and turned the car off then back on, was fine for a while, but could be recreated - always happened when I pushed the throttle. No error codes logged only sign was that cruise control became unavailable until I restarted. This turned out to be a blocked fuel filter.

Earlier this week, exactly the same signs, accelerate on motorway, as slight stutter/hiccup, dash says cruise control not available, the wee green cruise light goes out and I lose almost all power. Pull over restart and all fine for 10 mins then same again. So I think I know what this is - fuel filter. Had a spare in the boot so fitted it and on i went, 10 mins later same thing, so not the fuel filter. No errors logged in ecu. I bought a crank sensor on ebay for 15 fitted it and issue resolved, car is also noticeably smoother! 95k miles doesn't seem too bad for a 15 sensor. I'm fairly confident that even though both cases had exactly the same symptoms, they were different reasons - blocked fuel filter then Crank sensor.

My car did over heat a few months back resulting in the need for a new cylinder head. From what I can tell from Google over heating is a cause for this sensor to start to fail.

I have also noticed that acceleration is a bit smoother, no little jitters like before.

Only posting in case anyone else has had similar symptoms. Both items are fairly cheap and easy to change yourself. The crank sensor is below the starter motor and is awkward to get to. You cant see it from above unless you use a mirror. Using a mirror i changed mine from above in 30 mins, it was secured in place with a spline bit.
stuart.macintyr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

diesel , load , loss , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome