Light on Oil Temp Gauge - switching on and off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-03-15 Thread Starter
Status: -
AO Member
Join Date: Feb 2014
Location: Ireland
County: Cork
Posts: 12
Light on Oil Temp Gauge - switching on and off

When you put on the headlights on in the car sometimes the Oil temp gauge dosn't light up and other times it does , other times then it flickers on and off and might stay on or might stay off , did anybody have this problem ?
tiger72 is offline  
Sponsored Links
Status: Back in the Alfa Fold again
AO Member
SanRemo78's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Lancashire
Posts: 575
Sounds like a loose wire or bulb in the gauge?
SanRemo78 is offline  
Status: -
AO Member
outofspace's Avatar
Join Date: Jan 2012
Location: United Kingdom
County: Gloucestershire
Posts: 115
Get your battery checked, mine did this a couple of times before the battery died.
outofspace is offline  
Status: -
AO Silver Member
BuonGiorno's Avatar
Join Date: Aug 2013
Location: Russian Federation
County: St. Petersburg
Posts: 2,470
22JTS engine, is not it ???...
BuonGiorno is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

gauge , light , oil , switching , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome