Gremlins at startup - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-06-07 Thread Starter
Status: -
Join Date: Jun 2007
Location: South Africa
Posts: 3

Member car:

Alfa 159 1.9 Jts

Hmmm Gremlins at startup

Hi Folks,
I'm a newbie to the forum so please excuse any slip-ups. Have just re-entered the Alfa fold with a beautiful 1 year old silver 159 1.9 JTS. Awesome handling, stunning car but I have 1 major gremlin. Just after startup the engine sits at +- 1400rpm. It does so for almost a minute. During this time the idle is highly erratic. In some cases it is so bad there is clonking and banging from the engine bay (I think it is the engine rocking), with white smoke out the exaust. Dealer stated it was plugs which they replaced, but it is still doing it. The noise sounds almost like a cam belt slipping (rubber striking steel) which isn't possible as it's chain driven. The idle settles down after a minute to just over 1000rpm and all is well in the land again.
Has anyone had any similar experiences?
Many thanks.
Buccaneer is offline  
Sponsored Links
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: Gremlins at startup

Can't help Buccaneer other than to advise a return to the dealer, but can yu post your experience at please?
Fraser is offline  
Status: 660Nm of torqueystuff!
AO Platinum Member
Hunter's Avatar
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Re: Gremlins at startup

Return it to dealer and refuse to collect it until it's fixed to your satisfaction. Hope you get it sorted...
Hunter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

gremlins , startup

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome