Front Interior Light Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-02-15 Thread Starter
Status: decisions decisions!
AO Member
nikko's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Lancashire
Posts: 310

Member car:

159 TI

Front Interior Light Problem

All 3 lights within the front binnacle have stopped working, nothing via the switches or opening the doors. Rear unit works OK.
Surely it's unlikely all 3 bulbs would fail at once. Fuse is OK and owners manual says refer to dealer!
Anyone else had this problem?
nikko is offline  
Sponsored Links
Status: 16Italiancylinders(V 6,N4,L2,V2,V2)+1Span ish
AO Silver Member
swq4's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 1,508
Images: 28
I would try swapping over a fuse even if looks ok.
If that does not work, it is wiring/connectors or all three bulbs
swq4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

front , interior , light , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome