Electrical issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-02-15 Thread Starter
Status: Bespoke turbo FMIC fitted
AO Member
Pdw16396's Avatar
Join Date: Nov 2012
Location: United Kingdom
County: Essex
Posts: 270
Electrical issues

Hi all,
I have done severe electrical issues.
It seems to coincide with wet weather , guess I've got water getting into the electrics somewhere.
Starts with flickering headlights, then onto numerous dashboard warnings then engine cuts out.

Any ideas where I should look ?
Pdw16396 is offline  
Sponsored Links
Status: -
Club Member
Membro Premio
159_kid's Avatar
Club Member Number: 1398
Join Date: Oct 2010
Location: United Kingdom
Posts: 1,848
Dodgy earth strap?
159_kid is offline  
Status: -
AO Member
Join Date: Jul 2010
Location: United Kingdom
County: Hampshire
Posts: 12

Member car:


In diagnosing my electrical issues (thread elsewhere, to be updated when the work has been done on tuesday) I tracked my not dissimilar problems to the fusebox in the drivers footwell. I found that the car could be brought back to life by pulling the fusebox back and the problem could be re-created by pushing it forward. Must be a loose connection of some sort.

May be worth a try for the sake of 5 mins and a screwdriver.
gregg is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

electrical , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome