159 alarm!!! again!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-01-15 Thread Starter
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: North Lanarkshire
Posts: 314

Member car:

159 Ti

159 alarm!!! again!!

Hi Guys, quick question I'm hoping for help with

Last year, at 7am...my 159 decided it was time to wake up the street. I hit unlock (I think it was actually boot open, then unlock in quick succession) and the alarm started sounding. Nothing would stop it, neither the main key, spare key, unplugging the battery, starting the car etc etc - it just kept going off
The car would start fine etc

Eventually, after a lot of swearing I ran out of options, but it eventually died thankfully.
Anyway after that I got it to a garage and they diagnosed it as needing a new alarm control unit. I had this done and it seemed to have fixed the issue

Now tonight I came out to the car..hit boot unlock then open...and the alarm started again
Same issue, wouldn't stop, I even drove home with it going off. It eventually stopped again. Now I am terrified to arm the alarm!...The year old alarm...

My question is why could this be happening? As said the alarm was changed last year, and it's a new battery from last year too

Any suggestions would be great!
Chris0288 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alarm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome