Alternator trouble - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-12-14 Thread Starter
Status: -
AO Member
samlcampbell's Avatar
Join Date: May 2006
Location: Ayrshire
Posts: 378
Images: 1
Alternator trouble

My first breakdown in 80k miles, on a 300 mile journey home from Stoke Golding. Battery light came on after 10 miles and when I stopped to fill up the battery was dead. Very helpful garage owner tried all his contacts to find someone who could do the work without any luck. I searched on here and found Research garage in Nuneaton , recently appointed Alfa dealer. I was quoted 600 for genuine Alfa part, 418 for Bosch, or 402 for some other make. Being stranded and stuck , and as they could start at once I paid the 402. Also got a wash and vac thrown in, and offers of tea, coffee etc. They were very helpful and I could have had a free courtesy car. Not sure if I was overcharged or not. They did ask a lot of questions about Alfa ownership experience as they said they wanted to be learn and be successful.
samlcampbell is offline  
Sponsored Links
Status: -
AO Member
83DS's Avatar
Join Date: May 2013
Location: United Kingdom
County: South Yorkshire
Posts: 59

Member car:


I had the battery sign on a week or so ago, went back off as soon as I shut the car down and restart , battery tested and it's good
83DS is offline  
Status: -
AO Member
Join Date: Apr 2011
Location: United Kingdom
County: Lincolnshire
Posts: 741

Member car:

GT 1.9jtd

402 for an alternator ? my good god , better than being stuck i guess
bembo449 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

alternator , trouble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome