2.4jtdm power loss and other mysteries - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-12-14 Thread Starter
Status: 2.4 ti it is then
AO Member
Borojoss's Avatar
Join Date: Mar 2008
Location: Weardale
Posts: 119
Images: 13
2.4jtdm power loss and other mysteries

My 159 2.4ti had been running lumpy at idle and sluggish under 2000rpm till turbo kicked in. I removed and cleaned the egr which was coked up solid. Fitted a partial blanking plate (9mm hole). Cleaned the manifold sensor which was also gunked up. As soon as I started up I was met with a "Glow Plug Pre Heating Not Available" which id never seen before, checked all connections to see if id disturbed something, but its still showing and iv still got lumpy idle (but not all the time) and sluggish under about 2000rpm. Last week I noticed that when I shut the bonnet the vac pump on the slam panel starts buzzing loudly. Now yesterday to add to the woes while t mrs was going to work the car lost power, no warning lamps on dash. I managed to replicate the fault tonight and noticed the turbo boost gauge only moves about a quarter of the way up the gauge and won't rev past 2500rpm unless I dip the clutch. Lastly I can see one of the seals on the swirl flaps looks perished and damp around it. Great eh! after 4 years of trouble free ownership this all comes at once, its only done 50k.
Any suggestions would be appreciated. Im already thinking a new inlet manifold
Borojoss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

24jtdm , loss , mysteries , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome