Alfa 159 body computer - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-11-14 Thread Starter
Status: -
AO Member
Join Date: Mar 2010
Location: Australia
County: Queensland
Posts: 11
Alfa 159 body computer

Hi there

I'm having random error on my dash. Also my high beam stayed on when not on lights were off. Randomly stopped after a while.
Had the battery tray to gearbox earthing issues and my alternator seems to manage 13.1-13.4volts.
Battery also tests ok both voltage wise and cold cranking amps.
Can someone help.
Is the body computer failing ?
Can I use a used one to test in it's place ?

Dealer seems to have no idea. Suggested new battery and then alternator.
Aussiealfabear is offline  
Sponsored Links
Status: 1750TBIecusoftware.. done!.40+bhp
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480
Images: 10

Member car:

various Alfas

You can use a used one to test lights etc,but the car will not start
We can supply used body computers coded to another car but in your case is a bit difficult logistically as we need your old one so we can match the new one to(two lots of courier to and fro Aus etc)
ALFA TUNER is offline  
(Post Link) post #3 of 3 Old 07-12-14 Thread Starter
Status: -
AO Member
Join Date: Mar 2010
Location: Australia
County: Queensland
Posts: 11
think it new alternator required earth strap ....cleaned every connection i could find whether it looked dirty or not....13.7 consistently now.even with stereo on decent volume....which has two very large alpine amps quite capable of draining peaks of 200 A.

happy me thinks as been 9 days with no issues....
stupid earth problems...
Aussiealfabear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alternator , computer , low voltage

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome