water pump failed - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Rebuilding the Spider....slowly
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Hampshire
Posts: 102
Originally Posted by alfadodge View Post
When I got my 2010 1.75 TBi SW from Veloces 5 weeks ago, they said they would do the belt & water pump before I collected it because it was due to be done in 6 months anyway and they wanted me to have a year without having to worry about anything. The mileage was on just a tad over 40k.

Another member on here, Hedgeperson, also got his SW from them a few weeks before me and they did his belt & pump before collection too.

The parts cost (according to the no-charge invoice they gave me):
1750 belt kit (#SK15) - 52.50
Water Pump Twin Spark (#60586222) - 11.90
Anti Corrosion - 2.48 (?)
1m x 4mm Rubber Hose - 1.23 (?)

So very low cost items, just a shame there's such a high labour cost to fit them

But i'd definitely get back to Veloces, Dalewis, to check whether yours was changed and if not, why not?
It's strange as my experience of Vel***s could not have been any different when I bought my 1750 SW Ti from them late last year, shocking/abysmal/treated with disdain/couldn't care/ etc sums it up really. I've bought a lot of cars over the years from all sources but have never had a car purchase like this one!

I had to go back and ask kindly for the oil change the car should have had and that had been stamped up in the book by them, a cam belt change certainly wasn't offered despite it being due in 3K miles. I did briefly talk about the price for one but clearly they hadn't done one before and a water pump wasn't mentioned until I asked about the inclusion of that in the price. The oil change threw up a few question marks in my mind but I'm not committing them to writing.

My gut feeling was that there was no way the car was ever going back to them for servicing, through a bit of luck though I found Alfa Workshop and got them to do the 63K service. Totally different feel about the place and I felt that they actually cared about the customer and car, absolutely excellent service.

This isn't meant to be a moan but I felt the flip side of the coin with Vel***s needed to be said and with the likes of Alfa Workshop and Autolusso so close I'd personally recommend them instead.

Last edited by wal5; 09-05-15 at 07:48. Reason: Spelling
wal5 is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

failed , pump , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome