Central locking and electronics fault - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 26 Old 22-06-15 Thread Starter
Status: -
AO Member
Join Date: Nov 2014
Location: Norway
County: Hordaland
Posts: 17
Hi alfawest!
I had it fixed at a local workshop about a month ago, cost me about ? 850 for 5 hours of work. Dont live in Norway if you have car trouble.

The problem was a corroded cable/connection, underneath the carpeting on the driver side floor. The mechanic told me they had to remove the drivers seat to get to it.

Good luck! And while you're at it, you should check for waterleaks under the windshield wiper-tray, the drainage on the drivers side was clogged, and thats what caused the corrotion for me.
Alfanes is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 or , bodycomputer , canbus , centrallocking , lock or unlock

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome