eng temp and irratic idle problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 12-11-14 Thread Starter
Status: -
Join Date: Nov 2014
Location: United Kingdom
County: -
Posts: 2
Crazed eng temp and irratic idle problems

Hope some one can help I have a 159 2.4 diesel ***** the engine struggles to reach running temperatue in the winter running at about 2/3 its normal running temperature even in the summer it very rarely stays at the normal temperature dropping off when moving in traffic ,classic themostat fautl! My mechanic checked the themostat out and found no fault.

The more serious problem is that when the temperatue nears normal the car idles irratically only reverting back to normal when the temperature drops, Ive been told that the temperature sender also feeds the ECU for the fuel injection could that be the problem, if so how big a job is it and where is it fitted! Ive had a quick look but drew a blank. The car itself drives great plenty of power and performance but the poblem as been here for a while now and I am pretty sure the 2 faults are connected as the fault appears consistantly when normal running temperature is reached. hope some one out there might be able to help

Cheers Ossy Pete
ossy pete is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2014
Location: United Kingdom
County: Bedfordshire
Posts: 56

Member car:


Hi, had exactly the same issue. Search my other posts. I have just swapped out my thermostat and cleaned the throttle as it was caked up with soot. As it has been running cold (and therefore rich) it will be clogged up.

Ideally you would want to clean out the inlet manifold but unless you are due a belt change its a big job.

Make sure your egr is clear too.
benfinlayson is offline  
(Post Link) post #3 of 4 Old 12-11-14 Thread Starter
Status: -
Join Date: Nov 2014
Location: United Kingdom
County: -
Posts: 2
cheers for that ive been told about the throttle and manifold cloging up will first ask my mechanic if ihe cleaned them the last time he looked at it Ive already had timming belt done so i think he will have done it then I know he did the EGR valve. Its strange about the themostat it always stayed on constant normal before what else could affect it if its not a themostat fault
ossy pete is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
As always solve the cheap/ easy ones first

Any spelling/ grammatical errors are purely there to annoy!
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

eng , idle , irratic , problems , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome