aerial mount 159 wagon - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-10-14 Thread Starter
Status: My first Alfa and loving it!
AO Member
blueblood1995's Avatar
Join Date: Aug 2014
Location: Australia
County: Victoria
Posts: 196
aerial mount 159 wagon

Hi All
Quick question...
Had aerial off my 159 wagon today due to carrying a kayak.
Went to car wash on way home to wash salt water off kayak and car.
Now aerial mount (female thread) is full of water.
Got a few cotton buds inside the threaded section to push out excess water and soak as much as possible.
Would it be safe to reinstall aerial now or should I wait a day or two for it to completely evaporate.
Concerned about the potential for corrosion and then poor reception?
blueblood1995 is offline  
Sponsored Links
Status: -
AO Silver Member
alcooker's Avatar
Join Date: Sep 2008
Location: Hitchin
County: Hertfordshire
Posts: 1,920
alcooker is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , aerial , mount , wagon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome