Climate control-Heater problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 13-10-14 Thread Starter
Status: Need to dyno!
AO Member
Aeroresh's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Flintshire
Posts: 199
Images: 2
Help Climate control-Heater problem

Discovered my car has climate gremlins today.....suspected somethings up since I bought it in the summer to be honest.

Even after a AC regas the aircon kind of struggles when really hot can feel the chill in waves so I know the AC is working but its almost like the climate is holding it back somehow.

Anyway a further twist in that I turned the heater up to 'Hi' today and whilst it blows hot air out of the passenger side vents, it blows freezing cold out of the driver side! If I turn the driver side vents off it then blows warm air out of the passenger side.

some sort of blend door issue or electronics?

Any suggestions? Search function not pulling much out.
Aeroresh is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

I did see a thread a while back, the person said they got a little brush & dusted the mini air vent on the front of the AC/CC panel and it restored it's power.
Sounds mad, but it cost nothing to give it a try i suppose?
IAMBRERA is offline  
Status: All Hell's A-Coming
AO Platinum Member
Tata4Now's Avatar
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 26,919
There's a flap not working for hot/cold issue.

Could be too much gas for the cooling issue: pressure switch cutting out.
Tata4Now is online now  
(Post Link) post #4 of 5 Old 14-10-14 Thread Starter
Status: Need to dyno!
AO Member
Aeroresh's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Flintshire
Posts: 199
Images: 2
Will give it a quick dusting, cheers.

Ref the pressure switch cutting out, I note that the compressor seems to cycle on an off a fair bit. Would this be indicative of the fault?

I read a thread about actuator rods somewhere since I wrote the post although Im trying to get my head round which ones!
Aeroresh is offline  
Status: -
Join Date: Jun 2012
Location: United Kingdom
County: Oxfordshire
Posts: 7

Member car:

Brera 2.2 JTS SV

I've been having a similar problem on my Brera: cold air on the driver's side, hot on the passenger side. I suspected it was a problem with the actuator rods, and then one of the rods actually fell out into the driver's footwell yesterday, so I guess that's pretty conclusive!
68fastback is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

climate , controlheater , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome