Right headlight bulb not coming on - something to do with Electrics - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-10-14 Thread Starter
Status: -
Join Date: Sep 2014
Location: United Kingdom
County: Hampshire
Posts: 1
Help Right headlight bulb not coming on - something to do with Electrics

the right headlight bulb on my alfa 159 occasionally doesn't come on. last time i left it for a few days and it came back on by itself. Now its gone off again and i want to find out why and try to fix it.
I'm taking a guess and saying Moisture is getting to the electrics possibly? since on both occasions the light had gone off, it had been a rainy day before.
It doesn't always do this in the rain though so I'm a little confused.
I don't have much mechanical or electrical knowledge, so any idea what checks i can carry out to find out the issue?
parsamanesh is offline  
Sponsored Links
Status: New badges added :)
AO Member
AndyB2801's Avatar
Join Date: Jul 2014
Location: United Kingdom
County: Cheshire
Posts: 711

Member car:

Brera 2.2 JTS

This happened to me once when I changed my lights over to HiDs. Check all the connections on the back of the bulb (one of mine was a little loose and needed a wipe on the connection to remove a little dirt) mine hasn't reoccurred since. Hope this helps
AndyB2801 is offline  
Status: Need to dyno!
AO Member
Aeroresh's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Flintshire
Posts: 199
Images: 2
You might just find the bulb is on its way out...That would be the first thing Id check anyway. Had the same issue with a number plate lamp which you occasionally had to tap before it came on!
Aeroresh is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , headlight , moisture , rain

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome