Power Steering - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-09-14 Thread Starter
Status: -
AO Member
Join Date: Sep 2014
County: -
Posts: 61

Member car:


Power Steering

Hi all

Hope you can help. Recently bought a 159 and had the EML on already (as moaned about in my other thread!)

Something else I've experienced is the power steering seems a bit 'heavy'. There's no accompanying whining noise like some other posts on here, just a feint 'whoosh' when I turn the steering wheel either way.

When I say heavy I just mean that sometimes I feel I have to turn the wheel back to original position rather than wait for the wheel to do it itself as in my last car. This could of course be something entirely normal on Alfas, but any guidance would be appreciated.


Gjuk is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

Check your fluid first see if you have any left.
Check the alternator belt is still on
check for leaks underneath on the steering rack ends, also pipes & reservoir tank & the PAS pump.

With the bonnet up it's your first pulley wheel at the top of the engine follow the pipes from the reservoir to the pump.

Check for leaks with the engine running.
IAMBRERA is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

power , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome