159 2.4jtdm (2006) problems with injectors and bixenon lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-09-14 Thread Starter
Status: -
AO Member
Duke Nukem's Avatar
Join Date: Jul 2010
Location: Serbia
County: -
Posts: 24
159 2.4jtdm (2006) problems with injectors and bixenon lights

Hello, I have few issues that I cant understand fully on my 159 2.4

1. Car turns of when I press clutch or go to neutral very often. It is very unstable when on neutral (if it doesnt turn of) Injector correction times are:
cyl 1 2.53msec
cyl 2 0.24msec
cyl 3 0.65msec
cyl 4 1.53msec
cyl 5 2.64msec

I always tank it with high quality fuel with additives. There is a lot of black smoke when i rev it up a bit after it turns of.
I have done dpf and egr delete from software and egr blocked & dpf removed + mild chip tuning. It has all been done at professionals so I dont suspect that they messed anything.

2. Bixenon lights are too weak. I have philips 4300k d1s. I have tried 5000k brand new bulbs and still the same. I drove 2010 159 with cheapest h7 bulbs and they glow 3x better than my 700 bixenon lights.
What may be the cause of this? It's really frustrating, as I am not sure if the bulbs are dead as I dont see any reflection on the road (if there is any street light).
Duke Nukem is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , 2006 , 24jtdm , bixenon , injectors , lights , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome