Guidance Needed on MIL Alarms - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-09-14 Thread Starter
Status: drive or be driven!!
AO Member
Join Date: Jun 2007
Location: United Kingdom
County: North Ayrshire
Posts: 766
Guidance Needed on MIL Alarms


I keep getting a frequent MIL lamp for 2 sensor failures. They always reset, but come back if I am accelerating up a hill or accelerating if engine is not properly warmed up. One of them is Oxygen Sensor and the other I think translated is carbon dioxide heater sensor.

Not being a whizz with sensors, I could assume this could be linked to either the MAF or a lambda sensor, as I have 2 of these, 1 in the exhaust manifold and the other after the Cat.

Could a forum user advise if I have this correct or not....

Current :
Alfa 159 1.8 Turismo Sport

Previous Owns :
2004 Alfa 147 1.9 16v Mjet.
2005 Alfa 156 SW 2.4 20v Mjet.
2001 Alfa 156 SW 1.8 16v Twinnie.
1996 Alfa 164 2.0 TS Super Lusso
ScouseLad is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,205
O2 sensor sounds more like the MAF to me, on the black pipe near the headlight
giblets46 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

alarms , guidance , mil , needed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome