Rough start on 1.9 diesel - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 03-09-14 Thread Starter
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: Surrey
Posts: 68

Member car:


Rough start on 1.9 diesel

Hi all

Over the last year I have noticed that my 159 1.9 diesel starts really roughly and on ticking over it sounds too diesely (is that a word). I have had loads of work done including cam belt, battery, some injectors, some glow plugs..... the list goes on. Anyway when it starts it's more like a cough rather than a smooth turnover. I have the warning light saying 'glow plugs not available', would one or more non functioning glow plugs create this racket on start up. I was led to believe that glow plugs were not really an issue below 5 deg Celsius. Even when I have had the car running for a few hundred miles and it is properly hot it still restarts with a din.

Btw - I have 110k miles on the clock, so age could be an issue!

aliconor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

diesel , rough , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome