Brake system fault brera 2.2 s - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-08-14 Thread Starter
Status: feeling alfa pain in the wallet!
AO Member
sparty0_0's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hampshire
Posts: 257
Brake system fault brera 2.2 s

Afternoon all,

I have narrowed down my cruise control fault to the braking system , but need someone who know s more than me to shed some light on the problem .
I am getting the engine light on, VDC ASR and Hillholder , no cruise control , Unavailable and the fuel gauge dropping to zero when the fault occurs.

its showing a P0564 (multi function input circuit 'A')

i have changed the brake and clutch switch and they are working fine .

the fault occurs when you press the brake pedal and hold it about half way for more than 3 or 4 seconds. all the warings come up and the fuel gauge drops to zero.
the fault clears if you apply more OR less pressure to the brake pedal.

i have even disconnected the brake pedal wiring so as to rule the pedal switch out and the fault still triggers.!!!

this must mean that it to do with the braking or abs system its self .

does anyone know what it could possibly be ?

help urgently required please

or can someone recommend any one who would be able to get to the bottom of this issue. its already been to the main dealer and they are useless, and an auto electrician and my local specialist . Wopuld it be worth a trip to AutoLusso ? are they any good?

im in southampton by the way

sparty0_0 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brake , brera , fault , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome