Am thinking it's the water pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-08-14 Thread Starter
Status: -
AO Silver Member
Join Date: Aug 2014
Location: Jamaica
County: Saint Ann Parish
Posts: 1,705

Member car:

SV JTS 24V V6 Q4

Am thinking it's the water pump

Hi guys, first issue.
It's a bit long so please bare with me.
Several weeks ago i popped the bonnet to do some random checks & noticed my coolant level on low, so i sqaused my pipes & they felt floppy felt underneath the reservoir tank & around the pipes couldn't feel or see any leak, started the engine the coolant filled back up also the water pipes firmed back to normal too thought nothing more.

Two weeks or so late popped the bonnet again same issue, started the engine the pipes firmed up but the coolant stayed on low, so i turn the engine off made a mix of 60/40 antifreeze topped the tank back to max.

Fast forward two more weeks same issue with coolant, did more leak checks by putting the car in the air with the undertray off pressurised the coolant tank first with a type of pump with a screw cap on and waited with the engine off, slowly a drip started to form on the bottom of the left hand side of the radiator if your looking at the car head on, the drip would have taken about 5/10 seconds to fall before forming the next droplet of water/antifreeze, so i'm thinking it's a minor leak so i'll use a bottle of K seal for £10 did the trick stopped the leak fast but was the water pump gasket faulty too? Don't remember checking for that doh! but now i have noticed a rattle which i thought was coming from the alternator, so back to the garage car back in the air undertray off engine running the rattle sounds like a bearing rotating around which is driven from somewhere near the pulley's on the aux belt. Ruled out pas pump pulley & ac pump pulley that's making the noise, garage say it's not the alternator with 55k on the clock thought an alternator by bosch would last longer myself too.

So could it be the water pump propella? And that's what's making the rattle type noise? Water pumps on ebay go for as little as £33 on ebay so a part that is likely to go AWOL maybe? Any guess's or idea's guys?
IAMBRERA is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

pump , thinking , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome