My fun issues - 159 3.2 Q4 - battery terminals and struts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-06-14 Thread Starter
Status: -
Join Date: Mar 2014
Location: Australia
County: New South Wales
Posts: 4
My fun issues - 159 3.2 Q4 - battery terminals and struts

So after a short 3 months of having my gorgeous 159, I have had a couple of issues that I thought would be of value to post.

I have had a run in with the wonders of electronics and poor terminal connections.
The issues included loss of power, engine stalling - even whilst driving on the highway, car falling to start, cutting out with no dash lights, key-fob locking into the slot, vehicle protection system not active error displayed on the dash.

All of this caused by having the negative terminal corroded on the inside - looked immaculate from the outside, and one bolt loose on the positive terminal - to the fuse box.

Did think the battery had gone, and from some quick googling, it seemed like the key solt had broken, requiring replacement. Luckly it came to a much cheaper solution!

It definitely pays to double check your terminals!

My other issue was a clunk coming from the front whilst turning the steering wheel - either stationary or moving slowly.
I was lucky enough to be in Melbourne across the last week and called into Donnini Repairs. He managed to squeeze me in, even though he was packed out! Managed to track the issue down in about 15mins - the strut top bolts under the bonnet had come loose. He stated he had never seen that before on an Alfa. Not sure if they had worked their way loose or if they had previously been undone and forgotten to be done up! Worrying enough either way!

Hopefully a new strut bearing and some new bushes will make the rest of the clunk go away.

Cheers - Damo
Slats91 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , battery , fun , issues , struts , terminals

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome