Alfa 159 Grey Smoke on Start Up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-05-14 Thread Starter
Status: -
Join Date: Feb 2014
Location: United Kingdom
County: Greater London
Posts: 3

Member car:

159 (2.4) JTDM

Alfa 159 Grey Smoke on Start Up

Hi Folks,

I have an ALFA ROMEO 159 (2.4) JTDM TI QTRONIC 2009 which i have had for 3 months and love it. I have noticed a grey smoke on start up from the exhaust. It lets out a large puff of smoke but it seems too disappear as soon as you start driving. Its a little lumpy for a few seconds but the drive seems fine. Is this anything to worry about?

Any ideas or help would be much appreciated.


RichieC1970 is offline  
Sponsored Links
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Replace the glow plugs - BERU are recommended.
cj romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , alfa , grey , smoke , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome