2.4 squealing noise under partial throttle. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 21-04-14 Thread Starter
Status: -
AO Member
Join Date: Feb 2014
County: -
Posts: 32

Member car:

Alfa 159 2.4

2.4 squealing noise under partial throttle.

Occasionally getting a squealing noise under partial throttle on the drivers side and I am struggling to diagnose it. As soon as I come off the throttle it disappears. At first I thought aux belts but the problem doesn't occur while statically revving the engine. At WOT I also can't hear the noise, which I would have thought ruled out a boost leak. Anyone else had this issue? I guess the safest option is to have all belts and water pump done earlier (due in 20k miles) and try to see if I can find a boost leak? Thanks.
custardpants is offline  
Sponsored Links
Status: proud owner of a 159 too now
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Essex
Posts: 896
Images: 4
What is WOT. That's hard to find as it only happens underload . if you dip the clutch does it disappear.
I.d jack up the car and have a good look make sure nothing is rubbing plastic wheel arches etc.
I.d remove one of the aux belts and try as could be an idler or tension pulley, be careful the power steering might not work. Wheel bearing does it only do it when cornering left or right hand bend ?
If you can,t find anything could be water pump cambelt but you can,t see that without taking the cambelt cover off. How many years and miles ago were they done ?
phwspider is offline  
Status: service...done
AO Member
dazman5's Avatar
Join Date: May 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 650
my water pump did the occasional squeal, but didnt always happen. now it changed and the squeal has gone.
dazman5 is offline  
Status: Minus an Alfa.
AO Silver Member
Pete McK's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: North Yorkshire
Posts: 1,699
See if all your bolts are in the exhaust manifold. Mine occasionally lets out a little squeal as I need to refit a bolt and get a slight 'reed effect' from the gasket.
Pete McK is offline  
Status: [URL
AO Silver Member
Join Date: Oct 2007
Location: United Kingdom
County: Wrexham
Posts: 1,684
have a similar thing on my 16v jtdm, had hoped a cambelt, pump, etc would cure it and also i had a de swirl flapped manifold fitted at same time.
after a couple of drives its still there?
i only really get it on the same stretch of road when i first accelerate from coldish(which is why i hoped the new inlet manifold would stop it, incase it was leaking with swirl flaps in full open position etc ) as once its sqeeled(also i also thought boost leak sound) it then is usually not heard again in that journey(and i know it holds boost well and checked for leaks).
it always sounds near to the back of the steering wheel/dashboard corner , which is why ive not looked at turbo or exhaust manifold.
i suppose it could be a exhaust/turbo leak sealing once warm, it just doesnt sound in that area.
i might have a look at my map sensor o'ring as thats been in/out a few times it would fit that area sound wise.

sussexa is offline  
Status: -
Join Date: Apr 2014
Location: United Kingdom
County: Cornwall
Posts: 1

Member car:


I have this too in my 159 1.9 jtdm. I thought it may be drive shaft related as i can hear a slight drone at all times a bit like a wheel bearing, even when coasting. I think the two are related.

Its like, for a second or two, a sort of whoop, whoop, whoop at a certain speed and throttle position. Which i cant actually make happen, it just does.
Hedless Chiken is offline  
Status: -
AO Silver Member
BuonGiorno's Avatar
Join Date: Aug 2013
Location: Russian Federation
County: St. Petersburg
Posts: 2,473
I am not aware that is squealing exactly.
Nasty noice may comes from AirCo.
Some stuff inside is pinching.
Just switch it off - would be clear.

BuonGiorno is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

noise , partial , squealing , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome