Fuel pressure issue (159 2.2) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-04-14 Thread Starter
Status: -
AO Member
Join Date: Mar 2013
Location: Australia
County: New South Wales
Posts: 11
Fuel pressure issue (159 2.2)

Hi all,
I recently replaced the injectors and cleaned the valves in my 159, due to excessive carbon buildup and leaky/blocked injectors. However, after reassembly, the engine light came on, with error codes P1670 (fuel pressure -invalid signal) and P0191 (fuel pressure regulator - no signal). Also, whilst there are no issues starting the car, there is a chirping noise coming from the high pressure fuel pump area after the engine has warmed up, just like this (https://www.youtube.com/watch?v=iV_bnxYQouc). After cleaning the connection to the fuel pressure regulator, the P0191 error seems to have cleared, but P1670 and the noise remain. There aren't any fuel leaks or anything like that, and I am not aware of any problem with the high pressure fuel pump prior to this. I have tried driving the car, and there seems to be no issue running, except for unsteady RPMs at idle (probably due to inconsistent fuel pressure)
Does anyone know what the issue may be? I'm fairly sure the injectors were sealed in properly (brand new with brand new seals), but if they weren't, is there a possibility these are causing a fuel pressure issue?
azeng is offline  
Sponsored Links
Status: -
Join Date: May 2014
Location: United Kingdom
County: Buckinghamshire
Posts: 3

Member car:

alfa romeo 156

Hi I have a similar problem error p1670 and misfire on my alfa romeo 156 2.0 jts from 2002 and I heard that cojld be a electronic problem...could anybody give more details about this problem?
vasi_spatar is offline  
Status: -
AO Member
Join Date: Apr 2014
Location: United Kingdom
County: Conwy
Posts: 28
I'd check the fuel pressure regulator with a 'scope to check it's getting a signal.
brynllwynog2 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , fuel , issue , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome