Brake Booster Vacuum Issue?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-04-14 Thread Starter
Status: -
AO Member
Leighbo's Avatar
Join Date: Jun 2013
Location: Australia
County: Victoria
Posts: 13
Brake Booster Vacuum Issue??

Hello all! Model 2010 Alfa 159 JTS 2.2 - So i returned from a short 2 hour trip driving some pretty intense terrain not long ago. Whilst stopped at the first set of lights back in town my revs have dropped to about 500rpm with a really rough idle..... Symptoms now are due to extremely low revs, stiffness in brake pedal along with strong smell of fuel both in and out of the cabin.... My suspicion is a vacuum leak possibly near or at the brake booster. I have checked the air filter, and all gaskets around the block. There is no real obvious hissing noises although my ears are definitely not tuned to this sort of noise. Any other suggestions? If this is the likely culprit, where the hell is the location of the brake booster???? It looks like the vacuum line runs into the cabin on the drivers side? Do you have to rip everything out of the dash to get to it?

Please help??

Leighbo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

booster , brake , issue , vacuum

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome