Wiper problem (solved) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-04-14 Thread Starter
Status: -
AO Member
Join Date: Nov 2010
Location: United Kingdom
County: Kent
Posts: 254
Wiper problem (solved)

I came across a weird problem with the wipers recently and thought I'd share a quick post now I've found the cause, in case anyone else ever has the same thing.

The drivers side wiper arm was slipping rather than sweeping back and forth - most of the time it was OK, but sometimes when the screen was less than soaking wet, the arm would get stuck and then flail all over the place. Then, last weekend whilst on a dual carriageway, it started raining and the arm decided the best place to live was wrapped around the edge of the drivers door... eek!

I limped it home (via a layby until the rain abated), and took a look. It was a simple fix - the knurled spindle onto which the arm is pressed is slightly cone shaped, and then a nut on top pushes the base of the arm firmly onto this cone. All that had happened was the nut had loosened a little and so the arm wasn't so tightly pressed onto this cone-shaped spindle. I just moved the arm to the correct position and tightened the nut up firmly, and now all is well again. Cheap and easy!

Everyone else probably knows this already but it might save someone an hour's labour at a garage one day...
Mr_Mike is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

problem , solved , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome