Dead battery or worse? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Cry Like A Baby Dead battery or worse?

Came out to my Brera yesterday and on attempting to start it all I got from the starter was a whirring noise.

Charged the battery overnight but the same thing is happening this morning.

So, is it a really dead battery or somthing worse? All the dash lights seem OK, just no start.

If I disconnect the battery to get it checked, does the whole bloody car fall over? Do I need to follow a procedure or just whip the leads off?
Sponsored Links
Status: -
AO Member
Rossorichie's Avatar
Join Date: Feb 2013
Location: United Kingdom
County: Devon
Posts: 53
Can you jump start it?
Rossorichie is offline  
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,208
A whirring noise? was it turning over at all? When my batteries have died,, I got a clicking noise. or was the whiring from something else? Maybe the belt snapped? (that is a very wild stab in the dark!).
giblets46 is offline  
Status: service...done
AO Member
dazman5's Avatar
Join Date: May 2010
Location: United Kingdom
County: Cambridgeshire
Posts: 650
whirring noise sounds like the starter motor is spinning but not engaging with the flywheel. sometimes you can hit the top of it to shock it into engaging, but i doubt its got easy access.
if that's the case then there's nothing wrong with the battery.
dazman5 is offline  
Status: -
AO Member
Join Date: Jan 2012
Location: United Kingdom
County: Merseyside
Posts: 177

Member car:

Pug 106!!

What did you use to charge the battery? Sounds like a silly question, but the V6 has a battery with a large amount of cranking power and thus requires a powerful charger! Mine ran out of juice a couple of times and the best way to get it going was to either jump start it from another motor with a big battery (alot of modern diesel engines have a fairly pwerful battery), or to call out the rac/aa and have them use their booster packs.
Scouse_Dave is offline  
Status: -
AO Member
Join Date: Nov 2007
Location: United Kingdom
County: Edinburgh
Posts: 356
Images: 10
Look underneath and see if the earth cable has snapped or loose,my Brera stopped and would not start, the lights and dash lit up but nothing happend when I tried to start it,called out the AA they spotted it after a few minutes fixed another one on which they had with them, I started up and off she went,he told me to leave the engine running for half an hour when I got home and have had no problem since.
jamesy is offline  
Status: - Update
Posts: n/a
My money is still on the battery. It went down after the cold night on Tuesday. If the earth wire had snapped, the starter would not spin and I suspect that other warnings would appear. My charger is only small but it has never failed to charge a battery before, certainly enough to get the car to fire. My engine is a V6 so no belts to snap and anyway that would not result in a whirring noise, just a horrible clanking. Going to pull the battery in a bit and get it flash checked and replaced if required. This car did kill a battery at 2 years old before I owned it. The current battery is about therefore 6 years old and probably about due for a swap.
Status: - Update
Posts: n/a
Battery checked by shop in Nottingham. Apart from being dead flat, no signs of damage or deterioration. 24 hour charge off the car and after a bit of cranking, the beast fired. Just had to reset the electric windows, date and time. Everything else seems to have retained settings. Suppose I will just have to drive the car more to keep the battery fully charged.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

battery , dead , worse

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome