noise from wiper blades - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 07-03-14 Thread Starter
Status: -
Join Date: Mar 2014
Location: United Kingdom
County: Derbyshire
Posts: 8
noise from wiper blades


Does anyone else notice a wrattling/vibrating noise coming from the wipers (I think) when doing 40mph or more. Would replacing the blades fix this?


garyhall is offline  
Sponsored Links
Status: AO member
AO Member
Join Date: Sep 2005
Location: United Kingdom
County: Cheshire
Posts: 46
I had the same problem, got some new Bosch rubbers and it cured it. So quiet now. I think the rubber degrades and goes hard over time. The new ones are great but dont bother getting cheap ones, they can be just as bad.
Peter S is offline  
Status: Howling around Leicestershire
AO Silver Member
ferret-ears's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Leicestershire
Posts: 1,133
Images: 77
I found that if I used top quality screen washer fluid that stops the juddering you sometimes get.
Probably not your issue though.
ferret-ears is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

blades , noise , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome