Does this sound like the turbo has gone? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-03-14 Thread Starter
Status: -
Join Date: Apr 2013
Location: I would rather not say
County: -
Posts: 6
Does this sound like the turbo has gone?

Hi guys, I need some advice.

I have a 127,000 mile 2006 159 1.9 jtdm 16v, I have done 17,000 miles in 10 months and I love my car. HOWEVER two days ago driving home I thought my car made some odd noises for just a couple of seconds, bit like tools in a bag but I can't really remember then the power seemed to die off a little and I thought the turbo was spinning faster, but again I am not really sure.

Anyway I knew something was wrong as now I was definately down on power. I managed to limp home it was getting worse and worse when I tried to pull away from the lights, it took a few minutes to get up to 20 mph, clutch in revs went up, clutch out and the engine almost died.

Next day at 5am the car just about started, it was very lumpy and eventually started but I couldn't reverse, every time I realised the clutch the engine would die.

The RAC man thought it was the handbrake stuck on! Nope so he plugged his computer in and got three error codes, clutch switch intermittent, glow plug fault intermittent and Air flow permanent fault.

The garage looked at it said they thought there was another fault but the had to replace the air flow meter first. They did that today, now the are telling be the DPF filter was filthy but they did a forced regen, loads of muck and black smoke came out. However although it has improved they are telling me the turbo has gone and needs replacing. They are quoting 1200 for the work they have done so far and for the replacement which seems reasonable.

Sorry about the length of post but can anyone help, I just want to know what is the likely hood of a turbo failing out of the blue? and does it sould likely that this is the cause, the garage is not an alfa garage but has seemed good in the past.

billy164 is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
If you let us know where you are we may be able to recommend a good specialist, was it an Alfa garage, or random one?

Although there are a host of other issues, I would give the following thread a good look over, might give you an oppurtunity to rule out a few things (i'd check out the EGR, as mine went in tandom with the MAF, it doesn't tend to give any fault codes either.:
giblets46 is offline  
(Post Link) post #3 of 3 Old 06-03-14 Thread Starter
Status: -
Join Date: Apr 2013
Location: I would rather not say
County: -
Posts: 6
Hi thanks for the reply I am in Somerset/Dorset definitely not an Alfa garage just the closest to my house Red in Spetisbury is just too far ��. I will check the link, i had thought EGR could be a possibility but the garage assures me its not. So unless I think he is not telling the truth! I have to accept what he says.

Does anyone know if turbo failures give fault codes?

billy164 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , diesel , sound , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome