New upper wishbones - bad clunking? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 26-01-14 Thread Starter
Status: Busso
AO Silver Member
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,548
New upper wishbones - bad clunking?

Here's the story.

Our 159 SW TI was making all sorts of noises from the front, so I poked around with a pry bar and diagnosed wear in the rear bush of the upper wishbone. I got two new ones, proper TRW parts, as well as a pair of drop links for good measure.

I fitted them, and while the handling has hugely improved, there is a new noise, especially from the near side arm. As I jack the car up, the upper arm creaks - I can feel it creaking. It feels like movement in the metal centre of the bush. As the suspension moves, the rubber takes up some of the movement then forces the metal to move.

So far I have:

- loosened the bolts, and fired some silicone lube in there
- re tightened the bolts with the suspension loaded so that the centre of the bush is locked in the right place.
- tightened the bolts as hard as I can with an E18 spanner

This has reduced the noise, and it now only happens over big bumps, but it still happens, and presumably as the lube gets washed out, it will happen more and more.

Any ideas?
rxe is offline  
Sponsored Links
Status: -
AO Member
stu007's Avatar
Join Date: Jan 2013
Location: United Kingdom
County: Surrey
Posts: 288
Images: 21

Member car:

Alfa Mito

Mmm I had a similar problem when I fitted a new upper arm!! Discover in the end was given the wrong arm out of 2 possible types! Luckily was notice in time as was starting to chew were it mounted!
stu007 is offline  
(Post Link) post #3 of 5 Old 26-01-14 Thread Starter
Status: Busso
AO Silver Member
Join Date: Apr 2012
Location: United Kingdom
County: Berkshire
Posts: 2,548
As far as I understood, the differences in the arms was the ball joint taper. The ball joint is fine, very solid and not creaking. Were there differences in the bushes?
rxe is offline  
Status: -
tom14292's Avatar
Join Date: Jul 2015
Location: Oxford, UK
County: Oxfordshire
Posts: 9

Member car:

159 Sportwagon

I see this is well over a year ago but I am also suffering after a wishbone change and wondered if you managed to solve it?
tom14292 is offline  
Status: 60% Retired and still Pedantic
AO Member
Ken's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Falkirk
Posts: 896
Images: 32

Member car:

Alfa 159 3.2 Q4

I had some trouble with TRW arms. I had to send two back until I got some that didn't creak.
Luckily I got a pair of OE wishbones on eBay and they were perfect.
Ken is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

bad , clunking , upper , wishbones

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome