Boot lid conundrum? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 21-01-14 Thread Starter
Status: -
Join Date: Sep 2013
Location: United Kingdom
County: Kent
Posts: 5

Member car:


Help Boot lid conundrum?

Hello, this is only my second post so please forgive me if I do it wrong?

I have a 2010 159TI 1.9 diesel.
Recently the boot lid failed to open either on the key or by pushing the badge. According to a local main dealer they claim it needs a new boot lock despite the fact that they managed to open the lid by sending an electrical charge to the lock. Now that to me didn't sound right, as if the lock was faulty even with a charge it would fail to open.
I have checked the fault myself and have found that I can now open the boot using the key but not the badge button. So to me the lock is functioning but not the badge button. Having checked the micro switch on the badge with a volt meter that appears to be working however, when connected to the vehicles electrics it doesn't open the boot? All the boot wiring appears to be working.
Does anyone have an idea?
Casper76 is offline  
Sponsored Links
Status: Contra principia negantem non est disputandum
AO Silver Member
coxy1's Avatar
Join Date: Jun 2011
Location: Toliman
County: Toliman
Posts: 2,045
On mine the first sign of a low battery is the boot wont open, everything else is fine.
coxy1 is offline  
Status: proud owner of a 159 too now
AO Member
Join Date: Sep 2011
Location: United Kingdom
County: Essex
Posts: 896
Images: 4
There is a post on here about replaced cing the boot badge. Have a look at that. If you want to fix it yourself your first have to remove the inside trim so you can access the lock from inside. You can push the lock assembly in the boot with a screw driver then try and unlock it , see if the micro switch is activating by remote if it is but the lock does not move the solionod which operators the lock could be faulty , check fuse first if you can get a wiring diagram this will help you understand how it works. Might have a rely in circuit too.
phwspider is offline  
(Post Link) post #4 of 4 Old 23-01-14 Thread Starter
Status: -
Join Date: Sep 2013
Location: United Kingdom
County: Kent
Posts: 5

Member car:


Thanks guys. More investigation on my days off I think.
Casper76 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

boot , conundrum , lid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome