159 jtdm aircon trouble - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-01-14 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: Australia
County: Victoria
Posts: 33
159 jtdm aircon trouble

Hi there.
Having a trouble with my aircon those hot days.Driver side blowing cold enough while passenger side blowing hot air from the engine.Ive tried to change the settings auto-manual full auto same result.
Checked it with multiecuscan shows no errors but while checking the actuators says left mixing actuator not present while right is working.
Any ideas what can be the issue or is there any easy fix such as cable disconected or I should see a 'specialist'?
Any help welcomed.
nikola78 is offline  
Sponsored Links
Status: 159 Cruiser and Guilietta pocket rocket
AO Silver Member
giblets46's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Warwickshire
Posts: 4,198
You might need to fill up the coolant in the system, for some reason on the alfa one side fails before the other.
giblets46 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , aircon , jtdm , trouble

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome